GENASSYM.CF(5) File Formats Manual GENASSYM.CF(5)

genassym.cfassym.h definition file

The genassym.cf file is used by genassym.sh(8) to make constant C expressions known to assembler source files.

Lines starting with '#' are discarded by genassym.sh(8). Lines starting with , , , or are preceded with '#' and passed otherwise unmodified to the C compiler.

Lines starting with quote get passed on with the quote command removed.

The first word after a define command is taken as a CPP identifier and the rest of the line has to be a constant C expression. The output of genassym.sh(8) will assign the numerical value of this expression to the CPP identifier.


is a shorthand for
define foo foo.

struct foo
remembers foo for the member command and does a
define FOO_SIZEOF sizeof(foo),
with the structure name converted to upper case.

member foo
does a
define FOO offsetof(<last struct>, foo).
The two argument form of member, as
member foo bar
does a
define FOO offsetof(<last struct>, bar),
with its first argument converted to upper case. In the case where struct was invoked with an extra argument, as in
struct foo PREFIX_,
the first argument of member will be prefixed by the remembered prefix, before being converted to upper case.

union foo
is similar to the struct command, but applies to a union instead of a struct.


can be used to customize the output of genassym.sh(8).
When producing C output, values are cast to <ctype> (default: long) before they get handed to printf. <gcc constraint> (default: n) is the constraint used in the __asm__ statements. <asm print modifier> (default: empty) can be used to force gcc to output operands in different ways than normal. The "a" modifier e.g. stops gcc from emitting immediate prefixes in front of constants for the i386 port.

/sys/arch/${MACHINE}/${MACHINE}/genassym.cf

genassym.sh(8)

The first use of genassym.cf files occurred in OpenBSD 2.2. Its use was generalized to all ports for OpenBSD 3.0. The union command appeared in OpenBSD 3.5.

July 5, 2014 OpenBSD 7.5