GETSN(9) Kernel Developer's Manual GETSN(9)

getsnread user input from the console

#include <lib/libkern/libkern.h>

size_t
getsn(char *cp, size_t size);

The () function reads user input from the console and returns on newline. The result is written into cp, which is assumed to be size bytes long.

getsn() returns the total length of the string it tried to create.

April 25, 2018 OpenBSD 7.5