USBD_CLOSE_PIPE(9) Kernel Developer's Manual USBD_CLOSE_PIPE(9)

usbd_close_pipe, usbd_abort_pipedelete or abort transfers on a USB pipe

#include <dev/usb/usb.h>
#include <dev/usb/usbdi.h>

usbd_status
usbd_close_pipe(struct usbd_pipe *pipe);

void
usbd_abort_pipe(struct usbd_pipe *pipe);

The () function aborts any transfers queued on pipe.

The () function aborts any transfers queued on pipe then deletes it.

usbd_abort_pipe() and usbd_close_pipe() can be called during autoconf or from process context.

usb(4), usbd_open_pipe(9)

September 4, 2018 OpenBSD 7.5