WSFONT_INIT(9) Kernel Developer's Manual WSFONT_INIT(9)

wsfont_init, wsfont_find, wsfont_add, wsfont_remove, wsfont_enum, wsfont_lock, wsfont_unlock, wsfont_map_unicharwscons font support

#include <dev/wscons/wsconsio.h>
#include <dev/wsfont/wsfont.h>

void
wsfont_init(void);

int
wsfont_find(const char *name, int width, int height, int stride);

int
wsfont_add(struct wsdisplay_font *font, int copy);

int
wsfont_remove(int cookie);

void
wsfont_enum(int (*cb)(void *, struct wsdisplay_font *), void *cbarg);

int
wsfont_lock(int cookie, struct wsdisplay_font **ptr, int bitorder, int byteorder);

int
wsfont_unlock(int cookie);

int
wsfont_map_unichar(struct wsdisplay_font *font, int c);

The wsfont module is a component of the wscons framework to provide access to display fonts. Fonts may be loaded dynamically into the kernel or included statically in the kernel at compile time. Display drivers which emulate a glass-tty console on a bit-mapped display can add, remove and find fonts for use by device-dependent blitter operations.

The primary data type for manipulating fonts is the wsdisplay_font structure in <dev/wscons/wsconsio.h>:

struct wsdisplay_font {
	char name[WSFONT_NAME_SIZE];	/* font name */
	int index;
	int firstchar;
	int numchars;			/* size of font table */
	int encoding;			/* font encoding */
	u_int fontwidth;		/* character width */
	u_int fontheight;		/* character height */
	u_int stride;
	int bitorder;
	int byteorder;
	void *cookie;
	void *data;			/* pointer to font table */
};

The maximum font table size is WSDISPLAY_MAXFONTSZ.

The wsfont framework supports fonts with the following encodings:

ISO-encoded fonts.
IBM-encoded fonts commonly available for IBM CGA, EGA and VGA display adapters.

(void)
Initialise the font list with the built-in fonts.
(name, width, height, stride)
Find the font called name from the fonts loaded into the kernel. The font aspect is specified by width, height, and stride. If wsfont_find() is called with any of the parameters as 0, it indicates that we don't care about that aspect of the font. If the font is found, a (nonnegative-valued) cookie is returned which can be used with the other functions.

When more flexibility is required, () should be used.

(font, copy)
Add a font font to the font list. If the copy argument is non-zero, then the font is physically copied, otherwise a reference to the original font is made.
(cookie)
Remove the font specified by cookie from the font list. The value of cookie was returned by wsfont_add().
wsfont_enum(callback, cbarg)
Enumerate the list of fonts. For each font in the font list, the callback function argument is called with the cbarg argument.
wsfont_lock(cookie, ptr, bitorder, byteorder)
Lock access to the font specified by cookie so that it cannot be unloaded from the kernel while it is being used. If the bit or byte order of the font to be locked differs from what has been requested via the bitorder and byteorder arguments, then the glyph data will be modified to match.

The address of the wsdisplay_font pointer for the specified font is returned in the ptr argument.

() returns lockcount on success, or an error code on failure.

(cookie)
Unlock the font specified by cookie. Returns lockcount on success, or an error code on failure.
(font, c)
Remap the unicode character c to glyph for font font. Returns the glyph on success or -1 on error.

The wscons subsystem is implemented within the directory sys/dev/wscons. The wsfont subsystem itself is implemented within the file sys/dev/wsfont/wsfont.c.

wsfontload(8), intro(9)

May 10, 2019 OpenBSD 7.6